Apple IOS Spalding Phonograms App Compatibility

 

 

Compatibility:

 

 Requires Apple iOS 7.0 or later

 Compatible with iPhone, iPad, and iPod touch

 This app is optimized for iPhone 5, iPhone 6, and iPhone 6 Plus